summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2022-10-07 21:05:21 -0400
committerDavid King <amigadave@amigadave.com>2022-11-16 19:29:27 +0000
commit5944fefe139efc03df189f259e0742982499667e (patch)
treeba3a46e2dc3651ff8d87fde6f33f2f2882c72e1f /meson.build
parentc63f8e56cd85771bff97ed498a38810eb72bceb2 (diff)
downloadgnome-logs-5944fefe139efc03df189f259e0742982499667e.tar.gz
build: Use GNOME module post_install()
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 316d77a..26c6754 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-project('gnome-logs', 'c', version : '43.1', default_options : ['warning_level=1'])
+project('gnome-logs', 'c', version : '43.1', default_options : ['warning_level=1'], meson_version: '>= 0.57.0')
gl_name = meson.project_name()
gl_version = meson.project_version()
@@ -111,4 +111,7 @@ subdir('po')
subdir('help')
subdir('tests')
-meson.add_install_script('meson_post_install.py')
+gnome.post_install(
+ glib_compile_schemas: true,
+ gtk_update_icon_cache: true,
+)