summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDominique Leuenberger <dimstar@opensuse.org>2018-01-04 18:14:50 +0100
committerDominique Leuenberger <dimstar@opensuse.org>2018-01-04 18:57:53 +0100
commit099c19099de8e351f6cc0f2110ad27648780a0fe (patch)
tree81bf0998069a6c277aa34199a065fa597a28013e /meson.build
parent9ca73e68c1746bc835715aa4c521ba321b25ba27 (diff)
downloadgnome-session-099c19099de8e351f6cc0f2110ad27648780a0fe.tar.gz
Add a new switch to enable/disable forwarding to systemd journal
Allow distros that do wish to do so to disable logging to the systemd journal. Unless specified at 'configure time', the default remains to log to the journal. https://bugzilla.gnome.org/show_bug.cgi?id=768982
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ed6f1a83..e72a64e7 100644
--- a/meson.build
+++ b/meson.build
@@ -118,6 +118,7 @@ enable_session_selector = get_option('session_selector')
session_tracking = 'null backend'
enable_systemd = get_option('systemd')
+enable_systemd_journal = get_option('systemd_journal')
enable_consolekit = get_option('consolekit')
if enable_systemd or enable_consolekit
session_bin_deps += dependency('gio-unix-2.0', version: glib_req_version)
@@ -159,6 +160,7 @@ if enable_systemd or enable_consolekit
endif
endif
config_h.set('HAVE_SYSTEMD', enable_systemd)
+config_h.set('HAVE_SYSTEMD_JOURNAL', enable_systemd_journal)
config_h.set('HAVE_CONSOLEKIT', enable_consolekit)
configure_file(