summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJonas Dreßler <verdre@v0yd.nl>2021-04-12 20:49:10 +0200
committerMarge Bot <marge-bot@gnome.org>2021-04-26 12:18:52 +0000
commit1cefd589da2edca84d19b285d553e2a68cda3e37 (patch)
tree876eb777377b8fdb37cf2af72d5f3efdadf0d340 /meson.build
parentd7ad8da48d432cad3398e49e13f856ba5faece9a (diff)
downloadgnome-shell-1cefd589da2edca84d19b285d553e2a68cda3e37.tar.gz
st: Only use clutter_actor_invalidate_paint_volume() if the API exists
With commits fab39bbea5d9a7a0330a1be548f8ee26cd7e3131 and 62e40a13506b4481a50944be886b36566c464dc0 we started depending on a new ClutterActor API: clutter_actor_invalidate_paint_volume() Given that this commit was applied to the 40 stable release, it broke ABI compatibility with mutter, which is something we guarantee between stable releases. So use GModule to dynamically find the symbol in our loaded libraries. If it exists, use it and invalidate the paint volume. If it doesn't exist, libmutter is still at version 40.0 and we don't need to invalidate the paint volume. This also adds a dependency on gmodule. We need to link against gmodule to use g_module_open() and g_module_symbol() APIs. Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1807>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 14b75c1c9..359fa2a35 100644
--- a/meson.build
+++ b/meson.build
@@ -81,6 +81,7 @@ gi_dep = dependency('gobject-introspection-1.0', version: gi_req)
gio_dep = dependency('gio-2.0', version: gio_req)
gio_unix_dep = dependency('gio-unix-2.0', version: gio_req)
gjs_dep = dependency('gjs-1.0', version: gjs_req)
+gmodule_dep = dependency('gmodule-2.0')
gtk_dep = dependency('gtk+-3.0', version: gtk_req)
libxml_dep = dependency('libxml-2.0')
clutter_dep = dependency(clutter_pc, version: mutter_req)