summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRobert Mader <robert.mader@posteo.de>2021-04-01 01:08:12 +0200
committerMarge Bot <marge-bot@gnome.org>2021-07-07 14:44:30 +0000
commit3cfbb48f46ca96c968ed98a216595557faa2bf3a (patch)
tree1d075b8a36d060e4cf5ef51edf6768f1d49b6b36 /meson.build
parent757501b33aba194e0c674dbcb12e4f9e6959ad68 (diff)
downloadgnome-shell-3cfbb48f46ca96c968ed98a216595557faa2bf3a.tar.gz
main: Use mallinfo2 when available at build time
`mallinfo` has been deprecated in favor of `mallinfo2`: ``` The fields of the mallinfo structure that is returned by the older mallinfo() function are typed as int. However, because some internal bookkeeping values may be of type long, the reported values may wrap around zero and thus be inaccurate. ``` Part-of: <https://gitlab.gnome.org/GNOME/gnome-shell/-/merge_requests/1786>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c642a95e9..f0a2b4c55 100644
--- a/meson.build
+++ b/meson.build
@@ -158,6 +158,7 @@ cdata.set('HAVE_GIO_DESKTOP_LAUNCH_URIS_WITH_FDS',
)
cdata.set('HAVE_FDWALK', cc.has_function('fdwalk'))
cdata.set('HAVE_MALLINFO', cc.has_function('mallinfo'))
+cdata.set('HAVE_MALLINFO2', cc.has_function('mallinfo2'))
cdata.set('HAVE_SYS_RESOURCE_H', cc.has_header('sys/resource.h'))
cdata.set('HAVE__NL_TIME_FIRST_WEEKDAY',
cc.has_header_symbol('langinfo.h', '_NL_TIME_FIRST_WEEKDAY')