summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2020-03-02 18:03:34 -0500
committerW. Michael Petullo <mike@flyn.org>2020-03-02 18:03:34 -0500
commitb887451df89f51b62943c695c1449cef09233239 (patch)
tree250a65dfb204bc94231e5bdba2b7820cc65e10b6 /meson.build
parent9c72ac842a451dc0644fd7611c18a56e7b97676a (diff)
downloadgrilo-plugins-b887451df89f51b62943c695c1449cef09233239.tar.gz
dmap: support libdmapsharing-4.0 API
Add support for libdmapsharing's 4.0 API without removing support for the earlier API. The newer version takes precedence if both versions exist on the build host. The libdmapsharing 4.0 API better supports introspection and Vala. Distributions will likely take some time to migrate from libdmapsharing 3 to 4, and supporting both aids in this. Eventually, we should pull the support for libdmapsharing's 3.0 API. This involves removing grl-*-compat.h, reverting the references to the adapter functions therein back to direct references, and removing the related conditionals from meson.build and src/dmap/meson.build. Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 33a6f40..8a590b9 100644
--- a/meson.build
+++ b/meson.build
@@ -62,7 +62,12 @@ gstreamer_dep = dependency('gstreamer-1.0', required: false)
gthread_dep = dependency('gthread-2.0', required: false)
json_glib_dep = dependency('json-glib-1.0', required: false)
libarchive_dep = dependency('libarchive', required: false)
-libdmapsharing_dep = dependency('libdmapsharing-3.0', version: '>= 2.9.12', required: false)
+libdmapsharing4_dep = dependency('libdmapsharing-4.0', version: '>= 3.9.4', required: false)
+if libdmapsharing4_dep.found()
+ libdmapsharing_dep = libdmapsharing4_dep
+else
+ libdmapsharing_dep = dependency('libdmapsharing-3.0', version: '>= 2.9.12', required: false)
+endif
libgdata_dep = dependency('libgdata', version: '>= 0.9.1', required: false)
libmediaart_dep = dependency('libmediaart-2.0', required: false)
libsoup_dep = dependency('libsoup-2.4', required: false)