summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIgnacio Casal Quinteiro <qignacio@amazon.com>2018-11-16 12:04:50 +0100
committerCarlos Garnacho <carlosg@gnome.org>2018-12-11 14:30:32 +0100
commitb4a5c6032671d0d585a549418c991cd23ddd030c (patch)
treea52bdd823a4fc3b4a1d07a158587c1abd32b2d07 /meson.build
parent918efdd69be53275348cb52d3d6d9c9b205a4116 (diff)
downloadgsettings-desktop-schemas-b4a5c6032671d0d585a549418c991cd23ddd030c.tar.gz
Add meson build system
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build40
1 files changed, 40 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..7c214d7
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,40 @@
+project(
+ 'gsettings-desktop-schemas', 'c',
+ version: '3.31.0',
+ default_options: [
+ 'warning_level=2'
+ ],
+ license: 'LGPL',
+ meson_version: '>= 0.46.0'
+)
+
+gsettings_desktop_schemas_name = meson.project_name()
+gsettings_desktop_schemas_version = meson.project_version()
+
+message('Building ' + gsettings_desktop_schemas_name + ' ' + gsettings_desktop_schemas_version)
+
+cc = meson.get_compiler('c')
+host_system = host_machine.system()
+arch = host_machine.cpu_family()
+
+prefix = get_option('prefix')
+bindir = join_paths(prefix, get_option('bindir'))
+libdir = join_paths(prefix, get_option('libdir'))
+libexecdir = join_paths(prefix, get_option('libexecdir'))
+includedir = join_paths(prefix, get_option('includedir'))
+datadir = join_paths(prefix, get_option('datadir'))
+sysconfdir = join_paths(prefix, get_option('sysconfdir'))
+schemasdir = join_paths(datadir, 'glib-2.0/schemas')
+
+gnome = import('gnome')
+
+# Generate pc file
+pkg = import('pkgconfig')
+
+pkg.generate(name: gsettings_desktop_schemas_name,
+ version: gsettings_desktop_schemas_version,
+ description: 'Shared GSettings schemas for the desktop, including helper headers')
+
+subdir('headers')
+subdir('schemas')
+subdir('po')