summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2017-05-07 16:53:34 +0200
committerJens Georg <mail@jensge.org>2018-08-17 17:01:10 +0200
commit6c9ebf96f59c71e572a6791b789835877e75c2c1 (patch)
tree309a3f1abf5d43f906ce3a4711d3a785c38ee327 /meson.build
parentf634092d7397ed6df101423a732533e5c00a8a1a (diff)
downloadgssdp-6c9ebf96f59c71e572a6791b789835877e75c2c1.tar.gz
meson: Make introspection and vapi optional
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5a286e0..b8112ad 100644
--- a/meson.build
+++ b/meson.build
@@ -85,12 +85,21 @@ if not get_option('without-gtk')
gtk = dependency('gtk+-3.0', version : '>= 3.12', required: false)
endif
+gir = find_program('g-ir-scanner', required: false)
+vapigen = find_program('vapigen', required: false)
+
+introspection_available = gir.found() and not get_option('disable-introspection')
+vapi_available = introspection_available and vapigen.found() and not get_option('disable-vala')
+
subdir('libgssdp')
subdir('tests')
if not get_option('without-gtk') and gtk.found()
subdir('tools')
endif
-subdir('vala')
+
+if vapi_available
+ subdir('vala')
+endif
if get_option('enable-gtk-doc')
subdir('doc')