summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2016-02-18 10:47:36 +0100
committerJens Georg <mail@jensge.org>2018-10-31 20:17:43 +0100
commit9d278c48f2df9fdb136fa1032d367dd7ec9a5fb2 (patch)
tree840077c80884c9dcf9bffbdfd6b0681a2f4169c8 /meson.build
parent3f8dd1e3881cb025c104e3f123ab443afd784782 (diff)
downloadgssdp-9d278c48f2df9fdb136fa1032d367dd7ec9a5fb2.tar.gz
client: Add pktinfo handling for ipv6
Similar to v4 so that we can properly decide if the message is meant for us.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 57a9902..cd57def 100644
--- a/meson.build
+++ b/meson.build
@@ -8,8 +8,10 @@ conf = configuration_data()
conf.set_quoted('VERSION', meson.project_version())
# Check for struct in_pktinfo
-pktinfo_test = '''#include <netinet/ip.h>
+pktinfo_test = '''#define _GNU_SOURCE
+#include <netinet/ip.h>
struct in_pktinfo pktinfo;
+struct in6_pktinfo pktinfo6;
'''
pktinfo_available = cc.compiles(pktinfo_test,