summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2018-10-26 16:43:47 +0200
committerJens Georg <mail@jensge.org>2018-10-26 17:53:18 +0200
commita73d89ac886b6b09c28a976d08eef6ac44c040da (patch)
tree9e74c9f907292d9cf783741784aabf0486d597f1 /meson.build
parent1c8eb2e058f01034748c9fbfc1d088b888305db1 (diff)
downloadgssdp-a73d89ac886b6b09c28a976d08eef6ac44c040da.tar.gz
meson: Clean-up configure options
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 5 insertions, 20 deletions
diff --git a/meson.build b/meson.build
index 09d428e..f167152 100644
--- a/meson.build
+++ b/meson.build
@@ -2,13 +2,6 @@ project('GSSDP', 'c', version: '1.1.0')
gnome = import('gnome')
pkg = import('pkgconfig')
-as_version = meson.project_version() # set in project() below
-ver_arr = as_version.split('.')
-
-as_major_version = ver_arr[0]
-as_minor_version = ver_arr[1]
-as_micro_version = ver_arr[2]
-
cc = meson.get_compiler('c')
conf = configuration_data()
@@ -77,27 +70,19 @@ dependencies = [
dependency('libsoup-2.4', version : '>= 2.26.1')
]
-if get_option('ui')
- gtk = dependency('gtk+-3.0', version : '>= 3.12', required: false)
-endif
-
-gir = find_program('g-ir-scanner', required: false)
-vapigen = find_program('vapigen', required: false)
-
-introspection_available = gir.found() and get_option('introspection')
-vapi_available = introspection_available and vapigen.found() and get_option('vapi')
-
subdir('libgssdp')
subdir('tests')
-if get_option('ui') and gtk.found()
+
+if get_option('sniffer')
+ gtk = dependency('gtk+-3.0', version : '>= 3.12')
subdir('tools')
endif
-if vapi_available
+if get_option('vapi') and get_option('introspection')
subdir('vala')
endif
-if get_option('docs')
+if get_option('gtk_doc')
subdir('doc')
endif