summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2021-07-04 14:35:03 +0200
committerJens Georg <mail@jensge.org>2021-07-04 14:35:48 +0200
commite46ad6757e2396f45385a54e2ad9fbf1a36d2b60 (patch)
treee2e6bf7e26ff4f9f48ece9802fe82bda1e17416f /meson.build
parente2ba94f7e78833f78b7fafd420a046f3c8100ffb (diff)
downloadgssdp-e46ad6757e2396f45385a54e2ad9fbf1a36d2b60.tar.gz
win32: Add MAC lookup
This bumps the windows requirement to Vista
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index debb900..8ea7d30 100644
--- a/meson.build
+++ b/meson.build
@@ -36,10 +36,15 @@ siocgifindex_available = cc.compiles(siocgifindex_test,
name : 'SIOCGIFINDEX is available')
conf.set('HAVE_SIOCGIFINDEX', siocgifindex_available)
+getipnettable2_available = cc.compiles(files('build-aux/getipnettable2-test.c'), args: '-liphlpapi', name: 'GetIpNetTable2 is available')
+conf.set('HAVE_GETIPNETTABLE2', getipnettable2_available)
+
+
glib_version = '2.54'
conf.set('GLIB_VERSION_MIN_REQUIRED', 'GLIB_VERSION_@0@'.format(glib_version.underscorify()))
conf.set('GLIB_VERSION_MAX_ALLOWED', 'GLIB_VERSION_@0@'.format(glib_version.underscorify()))
+
# Generate config.h, so all config has to be set up until here
subdir('internal')