summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJussi Kukkonen <jku@openedhand.com>2008-06-18 09:44:24 +0000
committerJussi Kukkonen <jku@openedhand.com>2008-06-18 09:44:24 +0000
commit7b8e0d2871b3b10e92aa19c79e753ff01ab6836d (patch)
tree8d02c565ca48e629b3d509c3c4fc558e2f17628b /Makefile.am
parentff57143014dfea04c54dd4d6574e6b644c6fdaa2 (diff)
downloadgupnp-vala-7b8e0d2871b3b10e92aa19c79e753ff01ab6836d.tar.gz
* Makefile.am:
* configure.ac: * tests/Makefile.am: Update gssdp, gupnp and gupnp-av dependency versions. Make gupnp, gupnp-ui and gupnp-av optional dependencies (building without them will not build the respective bindings). git-svn-id: https://svn.o-hand.com/repos/gupnp/trunk/bindings/gupnp-vala@1103 d8cb91d7-bff9-0310-92b9-80b65e4482b2
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 02b8ac4..23573a5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,17 +6,23 @@ STAMP_FILES = gssdp-1.0.stamp
VAPI_FILES = gssdp-1.0.vapi
DEPS_FILES = gssdp-1.0.deps
+if WITH_GUPNP
STAMP_FILES += gupnp-1.0.stamp
VAPI_FILES += gupnp-1.0.vapi
DEPS_FILES += gupnp-1.0.deps
+endif
+if WITH_GUPNP_UI
STAMP_FILES += gupnp-ui-1.0.stamp
VAPI_FILES += gupnp-ui-1.0.vapi
DEPS_FILES += gupnp-ui-1.0.deps
+endif
+if WITH_GUPNP_AV
STAMP_FILES += gupnp-av-1.0.stamp
VAPI_FILES += gupnp-av-1.0.vapi
DEPS_FILES += gupnp-av-1.0.deps
+endif
gssdp-1.0.vapi: gssdp-1.0.stamp
@true