summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarvin Schmidt <marv@exherbo.org>2022-04-11 19:51:42 +0200
committerMarvin Schmidt <marv@exherbo.org>2022-04-11 20:06:03 +0200
commit9cabca33361bdba9e97f26437467eb041e5b7846 (patch)
tree1f01d420e8a7c71bd84bbc3b242e63b60f5476a4 /meson.build
parent174e80e5440a9e591d0d53ed5093659c6d945103 (diff)
downloadgupnp-9cabca33361bdba9e97f26437467eb041e5b7846.tar.gz
meson: Respect bindir option
Don't hardcode 'bin' (<prefix>/bin) but instead use the designated bindir option to get the install location for the binding tool
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7a6e488..e4cc56b 100644
--- a/meson.build
+++ b/meson.build
@@ -10,6 +10,9 @@ api_config = configuration_data()
api_config.set('GUPNP_API_VERSION', GUPNP_API_VERSION)
api_config.set('GUPNP_API_NAME', GUPNP_API_NAME)
+prefix = get_option('prefix')
+bindir = join_paths(prefix, get_option('bindir'))
+
netlink_available = cc.has_header('linux/rtnetlink.h')
ifaddrs_available = cc.has_header('ifaddrs.h')