summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJiří Techet <techet@gmail.com>2019-02-09 17:44:25 +0100
committerJiří Techet <techet@gmail.com>2019-02-09 17:44:25 +0100
commitbf3aee0c8869377d39de5ff6708b04fccfac559e (patch)
treeb0d02f94037c1b19dbbb63aa410b480ecbcf2013 /meson.build
parent7902c613dfe9650da448e3bf37beec0efc75be30 (diff)
downloadlibchamplain-bf3aee0c8869377d39de5ff6708b04fccfac559e.tar.gz
Combine champlain and champlain-gtk documentations into one
It makes no sense to keep them separate (especially when there's almost nothing in champlain-gtk). Building documentation requires gtk enabled now.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 318b110..31a96d6 100644
--- a/meson.build
+++ b/meson.build
@@ -72,7 +72,7 @@ libsoup_req = '>= 2.42'
memphis_req = '>= 0.2.1'
introspection_req = '>= 0.6.3'
vala_req = '>= 0.11.0'
-gtk_doc_req = '>= 1.9'
+gtk_doc_req = '>= 1.15'
glib_dep = dependency('glib-2.0', version: glib_req)
gobject_dep = dependency('gobject-2.0', version: glib_req)
@@ -102,16 +102,16 @@ configure_file(
# Options
build_demos = get_option('demos')
-build_gtk_doc = get_option('gtk_doc')
-if build_gtk_doc and not gtk_doc_dep.found()
- build_gtk_doc = false
-endif
-
build_gtk_widgetry = get_option('widgetry')
if build_gtk_widgetry and not (gtk_dep.found() and clutter_gtk_dep.found())
build_gtk_widgetry = false
endif
+build_gtk_doc = get_option('gtk_doc')
+if build_gtk_doc and not (gtk_doc_dep.found() and build_gtk_widgetry)
+ build_gtk_doc = false
+endif
+
generate_gir = get_option('introspection')
if generate_gir and not introspection_dep.found()
generate_gir = false