summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDebarshi Ray <debarshir@gnome.org>2016-12-01 19:30:00 +0100
committerDebarshi Ray <debarshir@gnome.org>2017-01-07 13:59:56 +0100
commit30681a486c0266b5fd0f2a984fba2d1b0dfe8d29 (patch)
tree7850ecc4867045fac25984d4bd524d25f0ca4302 /Makefile.am
parentee1dcc7a555a9cfc7790c517414aa51e84e6abbe (diff)
downloadlibgd-30681a486c0266b5fd0f2a984fba2d1b0dfe8d29.tar.gz
build: Add a main-icon-box flag to LIBGD_INIT
This includes GdMainIconBox, GdMainIconBoxChild, and everything under _box-common and gtk-hacks. https://bugzilla.gnome.org/show_bug.cgi?id=774914
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f8530b3..57cd1fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,6 +61,18 @@ nodist_libgd_la_SOURCES += $(box_common_sources)
EXTRA_DIST += $(box_common_sources)
endif
+if LIBGD_MAIN_ICON_BOX
+main_icon_box_sources = \
+ libgd/gd-main-icon-box.c \
+ libgd/gd-main-icon-box.h \
+ libgd/gd-main-icon-box-child.c \
+ libgd/gd-main-icon-box-child.h \
+ $(NULL)
+
+nodist_libgd_la_SOURCES += $(main_icon_box_sources)
+EXTRA_DIST += $(main_icon_box_sources)
+endif
+
if LIBGD__VIEW_COMMON
view_common_sources = \
libgd/gd-main-view-generic.c \