summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Dominic P. Guana <guana.histark@gmail.com>2020-05-26 18:53:49 +0800
committerRobert Roth <robert.roth.off@gmail.com>2020-11-04 13:38:03 +0000
commit7396970afe2290488fd072612a650353dd13a16d (patch)
tree4600f2a3144f25a578138164f85ef91c70aecfc3 /configure.ac
parent9cbb3b91f11ad0c4944a1428d609201c054cffab (diff)
downloadlibgtop-7396970afe2290488fd072612a650353dd13a16d.tar.gz
Code clean up and add example
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d7215bf0..5426daf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,6 +71,16 @@ dnl Most people should have a working perl interpreter on their system
AC_CHECK_PROGS(PERL, perl5 perl)
test -z "$PERL" && AC_MSG_ERROR([You need to have a working perl interpreter.])
+case "${host_os}" in
+ linux*)
+ AC_CHECK_TOOL(LSBLK,lsblk)
+ AC_CHECK_TOOL(SED,sed)
+ AC_CHECK_TOOL(TR,tr)
+ ;;
+ *)
+ ;;
+esac
+
AC_CHECK_TOOL(CC,gcc)
AC_CHECK_TOOL(RANLIB,ranlib)
AC_CHECK_TOOL(AS,as)