summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@src.gnome.org>1998-12-08 23:23:52 +0000
committerMartin Baulig <martin@src.gnome.org>1998-12-08 23:23:52 +0000
commit3da3f1b03f44b10897f92345d5e3d5c90f69a72b (patch)
tree59521df93ea55c8446c54706ad48bfd409306d22 /doc/Makefile.am
parentcd7ca97fc5a00b45aa57af4e11c877e71abc086a (diff)
downloadlibgtop-3da3f1b03f44b10897f92345d5e3d5c90f69a72b.tar.gz
Moved `doc' and `guile' subdirectories into the libgtop-docu module.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am53
1 files changed, 0 insertions, 53 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
deleted file mode 100644
index 79a85c62..00000000
--- a/doc/Makefile.am
+++ /dev/null
@@ -1,53 +0,0 @@
-htmldir = $(prefix)/html
-
-html_subdirs = libgtop gnome-hackers libgtop-ref table
-
-# Well, yes - you are using GNU Make, aren't you ... ?
-stamp_FILES = $(addsuffix .stamp,$(html_subdirs))
-sgml_FILES = $(addsuffix .sgml,$(html_subdirs))
-dsl_FILES = $(addsuffix .dsl,$(html_subdirs))
-
-EXTRA_DIST = $(sgml_FILES) $(dsl_FILES) dbtohtml.dsl autoconf.sgml
-
-noinst_DATA = $(stamp_FILES)
-
-CLEANFILES = $(stamp_FILES)
-
-distclean-local:
- -rm -rf $(html_subdirs)
-
-libgtop.sgml: libgtopConf.sh
-
-gnome-hackers.sgml: autoconf.sgml $(top_builddir)/guile/reference.sgml \
- features/uptime.sgml features/uptime.txt features/proclist.sgml \
- features/procmem.sgml
-
-libgtopConf.sh:
- @LN_S@ `@LIBGTOP_CONFIG@ --config`
-
-# You can set the $(JADE_FLAGS) in your shell to pass additional
-# arguments like `-D /usr/lib/sgml' to jade.
-
-SUFFIXES = .stamp .sgml
-.sgml.stamp:
- echo rm -f $@
- -rm -rf $*
- mkdir $*
- jade $(JADE_FLAGS) -D $(srcdir) -D . -D $(top_builddir)/guile \
- -d $(srcdir)/$*.dsl -t sgml -V %no-make-index% $< \
- > /dev/null && touch $@
-
-install-data-local:
- $(mkinstalldirs) $(htmldir)
- for subdir in $(html_subdirs) ; do \
- $(mkinstalldirs) $(htmldir)/$$subdir ; \
- for file in $$subdir/* ; do \
- $(INSTALL_DATA) $$file $(htmldir)/$$subdir ; \
- done \
- done
-
-dist-hook:
- mkdir $(distdir)/features
- cp -p $(srcdir)/features/*.sgml $(distdir)/features
- cp -p $(srcdir)/features/*.txt $(distdir)/features
-