summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>1999-09-28 23:37:29 +0000
committerMartin Baulig <martin@src.gnome.org>1999-09-28 23:37:29 +0000
commit8619b3a79b67e29c31ab5f7bf14390c50e6e41a0 (patch)
tree1185b013df68d0295d195e6be9d120abfc1ba233 /doc/Makefile.am
parentf71e60619d27cf9f05661571e945b25c77be3a65 (diff)
downloadlibgtop-8619b3a79b67e29c31ab5f7bf14390c50e6e41a0.tar.gz
Reverted Timur's commit. (MAKEINFO): Add `-I @libgtop_top_builddir@/doc'
1999-09-29 Martin Baulig <martin@home-of-linux.org> * Makefile.am: Reverted Timur's commit. (MAKEINFO): Add `-I @libgtop_top_builddir@/doc' here. This still creates libgtop.info in srcdir, but that's an automake problem.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 2e3b1e0b..4fedf0c6 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -2,7 +2,9 @@ info_TEXINFOS = libgtop.texi
libgtop_TEXINFOS = libgtop.texi about.texi reference.texi \
auto-macros.texi version.texi main.texi \
- white-paper.texi internals.texi
+ white-paper.texi
+
+MAKEINFO += -I @libgtop_top_builddir@/doc
EXTRA_DIST = auto-macros.texi.in
@@ -33,11 +35,11 @@ auto-macros.texi: auto-macros.texi.in Makefile
-e 's#\%libgtop_use_machine_h\%#$(libgtop_use_machine_h)#g' \
-e 's#\%libgtop_guile_found\%#$(libgtop_guile_found)#g' \
-e 's#\%libgtop_want_examples\%#$(libgtop_want_examples)#g' \
- < $(srcdir)/auto-macros.texi.in > $(srcdir)/auto-macros.tmp
- echo '@c Set this if this is LibGTop 1.1.x' >> $(srcdir)/auto-macros.tmp
+ < $(srcdir)/auto-macros.texi.in > auto-macros.tmp
+ echo '@c Set this if this is LibGTop 1.1.x' >> auto-macros.tmp
if [ $(LIBGTOP_VERSION_CODE) -ge 1001000 ] ; then \
- echo '@set LIBGTOP-1-1' >> $(srcdir)/auto-macros.tmp ; \
+ echo '@set LIBGTOP-1-1' >> auto-macros.tmp ; \
else \
- echo '@clear LIBGTOP-1-1' >> $(srcdir)/auto-macros.tmp ; \
+ echo '@clear LIBGTOP-1-1' >> auto-macros.tmp ; \
fi
- mv $(srcdir)/auto-macros.tmp $(srcdir)/auto-macros.texi
+ mv auto-macros.tmp auto-macros.texi