summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>1998-10-12 14:24:21 +0000
committerMartin Baulig <martin@src.gnome.org>1998-10-12 14:24:21 +0000
commit8f4611fe34f0924bf92c84571a6eec4d468a463b (patch)
tree695b37c045ad0f791ce800912d4985c98ff0be89 /doc/Makefile.am
parent27b46e687ba048d5845c02f76d99a190a92736be (diff)
downloadlibgtop-8f4611fe34f0924bf92c84571a6eec4d468a463b.tar.gz
New file. We are now using automake here. Removed. Since libgtop-docu now
1998-10-12 Martin Baulig <martin@home-of-linux.org> * Makefile.am: New file. We are now using automake here. * libgtopConf.sh: Removed. Since libgtop-docu now requires LibGTop to be installed we use the installed version of this file. * Makefile: Removed.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 00000000..79a85c62
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,53 @@
+htmldir = $(prefix)/html
+
+html_subdirs = libgtop gnome-hackers libgtop-ref table
+
+# Well, yes - you are using GNU Make, aren't you ... ?
+stamp_FILES = $(addsuffix .stamp,$(html_subdirs))
+sgml_FILES = $(addsuffix .sgml,$(html_subdirs))
+dsl_FILES = $(addsuffix .dsl,$(html_subdirs))
+
+EXTRA_DIST = $(sgml_FILES) $(dsl_FILES) dbtohtml.dsl autoconf.sgml
+
+noinst_DATA = $(stamp_FILES)
+
+CLEANFILES = $(stamp_FILES)
+
+distclean-local:
+ -rm -rf $(html_subdirs)
+
+libgtop.sgml: libgtopConf.sh
+
+gnome-hackers.sgml: autoconf.sgml $(top_builddir)/guile/reference.sgml \
+ features/uptime.sgml features/uptime.txt features/proclist.sgml \
+ features/procmem.sgml
+
+libgtopConf.sh:
+ @LN_S@ `@LIBGTOP_CONFIG@ --config`
+
+# You can set the $(JADE_FLAGS) in your shell to pass additional
+# arguments like `-D /usr/lib/sgml' to jade.
+
+SUFFIXES = .stamp .sgml
+.sgml.stamp:
+ echo rm -f $@
+ -rm -rf $*
+ mkdir $*
+ jade $(JADE_FLAGS) -D $(srcdir) -D . -D $(top_builddir)/guile \
+ -d $(srcdir)/$*.dsl -t sgml -V %no-make-index% $< \
+ > /dev/null && touch $@
+
+install-data-local:
+ $(mkinstalldirs) $(htmldir)
+ for subdir in $(html_subdirs) ; do \
+ $(mkinstalldirs) $(htmldir)/$$subdir ; \
+ for file in $$subdir/* ; do \
+ $(INSTALL_DATA) $$file $(htmldir)/$$subdir ; \
+ done \
+ done
+
+dist-hook:
+ mkdir $(distdir)/features
+ cp -p $(srcdir)/features/*.sgml $(distdir)/features
+ cp -p $(srcdir)/features/*.txt $(distdir)/features
+