summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>1999-05-16 12:31:58 +0000
committerMartin Baulig <martin@src.gnome.org>1999-05-16 12:31:58 +0000
commitbedec591a2bbba536b08afc462710e7b11c31273 (patch)
tree6c8ed1d1a8b2bfa907ed6b96aa9de021572206bf /doc/Makefile.am
parent2c4568119c4c1eb922acb90e90951d58dbe5263f (diff)
downloadlibgtop-bedec591a2bbba536b08afc462710e7b11c31273.tar.gz
We can't call that file `version.texi' since that's some king of "magic"
name for automake, so I renamed it to `auto-macros.texi'. 1999-05-16 Martin Baulig <martin@home-of-linux.org> * Makefile.am: Create `auto-macros.texi' from `auto-macros.texi.in' which will contain some `@set' commands for the LibGTop version etc. * auto-macros.texi.in: New file. This is a template for `auto-macros.texi' which will be automatically generated.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am17
1 files changed, 9 insertions, 8 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 6de95c68..a262481e 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,10 +1,11 @@
info_TEXINFOS = libgtop.texi
-libgtop_TEXINFOS = libgtop.texi about.texi reference.texi version.texi
+libgtop_TEXINFOS = libgtop.texi about.texi reference.texi \
+ auto-macros.texi
-EXTRA_DIST = version.texi.in
+EXTRA_DIST = auto-macros.texi.in
-version.texi: version.texi.in Makefile
+auto-macros.texi: auto-macros.texi.in Makefile
## Use sed and then mv to avoid problems if the user interrupts.
sed -e 's#\%LIBGTOP_LIBDIR\%#$(libdir)#g' \
-e 's#\%LIBGTOP_INCLUDEDIR\%#$(includedir)#g' \
@@ -31,11 +32,11 @@ version.texi: version.texi.in Makefile
-e 's#\%libgtop_use_machine_h\%#$(libgtop_use_machine_h)#g' \
-e 's#\%libgtop_guile_found\%#$(libgtop_guile_found)#g' \
-e 's#\%libgtop_want_examples\%#$(libgtop_want_examples)#g' \
- < $(srcdir)/version.texi.in > version.tmp
- echo '@c Set this if this is LibGTop 1.1.x' >> version.tmp
+ < $(srcdir)/auto-macros.texi.in > auto-macros.tmp
+ echo '@c Set this if this is LibGTop 1.1.x' >> auto-macros.tmp
if [ $(LIBGTOP_VERSION_CODE) -ge 1001000 ] ; then \
- echo '@set LIBGTOP_1_1' >> version.tmp ; \
+ echo '@set LIBGTOP_1_1' >> auto-macros.tmp ; \
else \
- echo '@clear LIBGTOP_1_1' >> version.tmp ; \
+ echo '@clear LIBGTOP_1_1' >> auto-macros.tmp ; \
fi
- mv version.tmp version.texi
+ mv auto-macros.tmp auto-macros.texi