summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>1998-11-02 20:50:47 +0000
committerMartin Baulig <martin@src.gnome.org>1998-11-02 20:50:47 +0000
commit0882a71244f775fb6ac2f803b2433c9b3be81ca8 (patch)
tree5b11abc22359852fa9ede5b42cf5ba25d1ed235f /examples/Makefile.am
parent213647b20351da1df2fa1d838fd0618266ec1b71 (diff)
downloadlibgtop-0882a71244f775fb6ac2f803b2433c9b3be81ca8.tar.gz
New example.
1998-11-02 Martin Baulig <martin@home-of-linux.org> * sysdeps.c: New example.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index f1ada8ec..daeb557b 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -12,14 +12,13 @@ DEFS = @DEFS@
libgtopdir = $(libexecdir)/libgtop
libgtop_PROGRAMS = first second\
- mountlist procmap netload \
- @static_targets@ \
- @guile_examples@ @smp_examples@
+ mountlist procmap netload sysdeps\
+ @static_targets@ @guile_examples@ @smp_examples@
EXTRA_PROGRAMS = first_static second_static \
mountlist_static procmap_static \
third third_static smp smp_static \
- netload_static
+ netload_static sysdeps_static
first_SOURCES = first.c
first_LDADD = $(top_builddir)/lib/libgtop.la \
@@ -63,7 +62,15 @@ netload_static_SOURCES = $(netload_SOURCES)
netload_static_LDADD = $(netload_LDADD)
netload_static_LDFLAGS = -static
+sysdeps_SOURCES = sysdeps.c
+sysdeps_LDADD = $(top_builddir)/lib/libgtop.la \
+ $(top_builddir)/sysdeps/common/libgtop_common.la \
+ $(top_builddir)/sysdeps/@sysdeps_dir@/libgtop_sysdeps.la \
+ @INTLLIBS@ @LIBSUPPORT@
+sysdeps_static_SOURCES = $(sysdeps_SOURCES)
+sysdeps_static_LDADD = $(sysdeps_LDADD)
+sysdeps_static_LDFLAGS = -static
third_guile_names_LIBS = $(top_builddir)/sysdeps/guile/names/libgtop_guile_names.la
third_names_LIBS = $(top_builddir)/sysdeps/names/libgtop_names.la