summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@src.gnome.org>1998-05-19 18:19:50 +0000
committerMartin Baulig <martin@src.gnome.org>1998-05-19 18:19:50 +0000
commit33cdc01c1db3a1cafaeb63e50247072b82ef49ea (patch)
tree765262671f242fc45d3504cc069636ced714e33b /examples/Makefile.am
downloadlibgtop-33cdc01c1db3a1cafaeb63e50247072b82ef49ea.tar.gz
Initial revision
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
new file mode 100644
index 00000000..6c50866d
--- /dev/null
+++ b/examples/Makefile.am
@@ -0,0 +1,66 @@
+## Process this file with automake to produce Makefile.in
+
+LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -o $@
+
+INCLUDES = @GTOP_INCS@
+
+CFLAGS = -Wall -W @CFLAGS@
+
+DEFS = @DEFS@
+
+bin_PROGRAMS = first first_static first_linux \
+ second second_static second_linux \
+ @guile_examples@
+
+EXTRA_PROGRAMS = third third_static third_linux
+
+first_SOURCES = first.c
+first_LDADD = $(top_builddir)/sysdeps/common/libgtop_common.la \
+ $(top_builddir)/lib/libgtop.la \
+ @INTLLIBS@ @LIBSUPPORT@
+
+first_static_SOURCES = $(first_SOURCES)
+first_static_LDADD = $(first_LDADD)
+first_static_LDFLAGS = -static
+
+first_linux_SOURCES = $(first_SOURCES)
+first_linux_LDADD = $(top_builddir)/sysdeps/common/libgtop_common.la \
+ $(top_builddir)/sysdeps/@sysdeps_dir@/libgtop_sysdeps.la \
+ @INTLLIBS@ @LIBSUPPORT@
+first_linux_LDFLAGS = -static
+
+second_SOURCES = second.c
+second_LDADD = $(top_builddir)/sysdeps/common/libgtop_common.la \
+ $(top_builddir)/lib/libgtop.la \
+ @INTLLIBS@ @LIBSUPPORT@
+
+second_static_SOURCES = $(second_SOURCES)
+second_static_LDADD = $(second_LDADD)
+second_static_LDFLAGS = -static
+
+second_linux_SOURCES = $(second_SOURCES)
+second_linux_LDADD = $(top_builddir)/sysdeps/common/libgtop_common.la \
+ $(top_builddir)/sysdeps/@sysdeps_dir@/libgtop_sysdeps.la \
+ @INTLLIBS@ @LIBSUPPORT@
+second_linux_LDFLAGS = -static
+
+third_SOURCES = third.c
+third_LDADD = $(top_builddir)/sysdeps/guile/libgtop_guile.la \
+ $(top_builddir)/sysdeps/guile/names/libgtop_guile_names.la \
+ $(top_builddir)/sysdeps/names/libgtop_names.la \
+ $(top_builddir)/sysdeps/common/libgtop_common.la \
+ $(top_builddir)/lib/libgtop.la \
+ @GUILE_LIBS@ @INTLLIBS@ @LIBSUPPORT@
+
+third_static_SOURCES = $(third_SOURCES)
+third_static_LDADD = $(third_LDADD)
+third_static_LDFLAGS = -static
+
+third_linux_SOURCES = $(third_SOURCES)
+third_linux_LDADD = $(top_builddir)/sysdeps/guile/libgtop_guile.la \
+ $(top_builddir)/sysdeps/guile/names/libgtop_guile_names.la \
+ $(top_builddir)/sysdeps/names/libgtop_names.la \
+ $(top_builddir)/sysdeps/common/libgtop_common.la \
+ $(top_builddir)/sysdeps/@sysdeps_dir@/libgtop_sysdeps.la \
+ @GUILE_LIBS@ @INTLLIBS@ @LIBSUPPORT@
+third_linux_LDFLAGS = -static