summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2014-02-11 14:10:46 -0500
committerRyan Lortie <desrt@desrt.ca>2014-02-20 20:58:16 -0500
commite682094418076e286198d1ae6f0ed8448bde5db2 (patch)
tree94688681bec1a3d4efd86329195ab6a2be7f2c6c /examples/Makefile.am
parent2e861977a66bf095d310e90534618134415de197 (diff)
downloadlibgtop-e682094418076e286198d1ae6f0ed8448bde5db2.tar.gz
examples: don't override LINK and other variables
Defining our own LINK causes us to run into some trouble with LDFLAGS, which commit 16bb5c8075ae3d18fa3b19fdd1b479b4cf17a96b already demonstrated. LDFLAGS does need to be included here, but it's probably even easier to just use the default value. https://bugzilla.gnome.org/show_bug.cgi?id=724195
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am6
1 files changed, 0 insertions, 6 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 5ac77526..ddbf80a0 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,11 +1,5 @@
## Process this file with automake to produce Makefile.in
-LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(AM_LDFLAGS) -o $@
-
-INCLUDES = @INCLUDES@
-
-DEFS = @DEFS@
-
AM_LDFLAGS = $(LIBGTOP_EXTRA_LIBS)
noinst_PROGRAMS = first second pprint procargs df netlist \