summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>1999-02-18 09:54:18 +0000
committerMartin Baulig <martin@src.gnome.org>1999-02-18 09:54:18 +0000
commit2deb3c30c4ea99164969bb5711da02b7f05bef51 (patch)
treecc296b88d5dbf1fdd89270421328309c143dce73 /lib/Makefile.am
parent00f0791ebdf380c5b728d22fe5920528a25b79a7 (diff)
downloadlibgtop-2deb3c30c4ea99164969bb5711da02b7f05bef51.tar.gz
Replaced all awk scripts with perl scripts since it is more likely that
1999-02-18 Martin Baulig <martin@home-of-linux.org> * */*.awk: Replaced all awk scripts with perl scripts since it is more likely that people have a working perl interpreter than GNU awk on their system.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 1ab3f33c..7120f4ca 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -12,11 +12,11 @@ libgtop_la_LDFLAGS = $(LT_VERSION_INFO)
BUILT_SOURCES = lib.c
-lib.c: lib.awk $(top_builddir)/config.h $(top_srcdir)/features.def
- $(AWK) -f $(srcdir)/lib.awk < $(top_srcdir)/features.def > lib-t
+lib.c: lib.pl $(top_builddir)/config.h $(top_srcdir)/features.def
+ $(PERL) $(srcdir)/lib.pl < $(top_srcdir)/features.def > lib-t
mv lib-t lib.c
-EXTRA_DIST = lib.awk
+EXTRA_DIST = lib.pl
CLEANFILES = lib.c