summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <baulig@suse.de>2000-11-20 22:37:15 +0000
committerMartin Baulig <martin@src.gnome.org>2000-11-20 22:37:15 +0000
commit752d5b47d2134cd6e76465943aadcdcb0ea5e777 (patch)
tree062defcfdaa4a83273e1c0112025f725a74f4332 /lib/Makefile.am
parentc15ff3f342e7f5eb74a5f5867ebe87c89d9a5cb0 (diff)
downloadlibgtop-752d5b47d2134cd6e76465943aadcdcb0ea5e777.tar.gz
Started with the big rewrite for GNOME 2.0:
2000-11-20 Martin Baulig <baulig@suse.de> Started with the big rewrite for GNOME 2.0: - split the `glibtop' structure into `glibtop_server' and `glibtop_client' and make `glibtop_client' a GObject. - cleanly separate the library and the backends. This stuff currently does not compile. * glibtop.h (glibtop_server_private, glibtop_server_info): Removed typedefs. (struct _glibtop, struct _glibtop_server_info): Removed. (glibtop_global_server, glibtop_server_features): Removed. (glibtop_server_ref, glibtop_server_unref): Removed. * glibtop.h (glibtop_init_s): First argument is now a `glibtop_server *'. * include/glibtop/*.h: Removed all #defines with the glibtop_global_server. (glibtop_get_*_l): First argument is now a `glibtop_client *'. (glibtop_get_*_s, glibtop_init_*_s): First argument is now a `glibtop_server *'. * lib/glibtop-client.c: New file. * sysdeps/common/xmalloc.c: Moved to lib/. * sysdeps/common/error.c: Moved to lib/. * lib/xmalloc.c: Moved here from sysdeps/common/. * lib/error.c: Moved here from sysdeps/common/. * include/glibtop/backend.h (glibtop_backend_open_func_t, glibtop_backend_close_func_t): First argument is now a `glibtop_server *'. (glibtop_backend_info): Added `glibtop_server *server'. (glibtop_open_backend_l): Returns `glibtop_backend *', first argument is `glibtop_client *' and added `GError **'. * include/glibtop/close.h (glibtop_close_s, glibtop_close_p): First argument is now a `glibtop_server *'. * include/glibtop/error.h (*): First argument is now a `glibtop_server *'. * include/glibtop/errors.h: Switched this to use GError.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index e09b2cf3..9f7a2318 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -2,12 +2,15 @@ LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -o $@
INCLUDES = @INCLUDES@
-lib_LTLIBRARIES = libgtop.la
+lib_LTLIBRARIES = libgtop.la libgtop_server.la
-libgtop_la_SOURCES = init.c open.c close.c lib.c parameter.c \
- sysdeps.c errors.c glib-arrays.c \
- backend.c init-backends.c open-backend.c \
- sysdeps-init.c
+libgtop_la_SOURCES = errors.c glib-arrays.c backend.c \
+ init-backends.c open-backend.c \
+ glibtop-client.c
+
+libgtop_server_la_SOURCES = error.c xmalloc.c
+
+libgtop_server_la_LDFLAGS = $(LT_VERSION_INFO)
libgtop_la_LDFLAGS = $(LT_VERSION_INFO)
libgtop_la_LIBADD = $(LIBGTOP_XML_LIB)