summaryrefslogtreecommitdiff
path: root/sysdeps/solaris/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>2000-02-22 19:58:58 +0000
committerMartin Baulig <martin@src.gnome.org>2000-02-22 19:58:58 +0000
commit00d9dd7065fd7b4a3e55e27edb14925041dff141 (patch)
tree66b5822ec28f14b8aac294f17854e916e57e2690 /sysdeps/solaris/Makefile.am
parent0a3a0c1a349c615aedf281dd2657bcc8d5f7bc3a (diff)
downloadlibgtop-00d9dd7065fd7b4a3e55e27edb14925041dff141.tar.gz
Added this to CVS and hacked it to use `$CC -shared' to create shared
2000-02-22 Martin Baulig <martin@home-of-linux.org> * ltconfig: Added this to CVS and hacked it to use `$CC -shared' to create shared libraries on Solaris. * automake.sh: Don't run libtoolize on Solaris but use the CVS version instead.
Diffstat (limited to 'sysdeps/solaris/Makefile.am')
-rw-r--r--sysdeps/solaris/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/sysdeps/solaris/Makefile.am b/sysdeps/solaris/Makefile.am
index 760214c9..2d6c26bc 100644
--- a/sysdeps/solaris/Makefile.am
+++ b/sysdeps/solaris/Makefile.am
@@ -2,7 +2,11 @@ LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -o $@
INCLUDES = @INCLUDES@
-lib_LTLIBRARIES = libgtop_sysdeps.la libgtop_sysdeps_suid.la
+dynamic_ldflags = @libgtop_dynamic_ldflags@
+
+backenddir = @LIBGTOP_BACKEND_DIR@
+
+backend_LTLIBRARIES = libgtop_sysdeps.la libgtop_sysdeps_suid.la
libgtop_sysdeps_la_SOURCES = open.c close.c cpu.c mem.c \
safeio.c swap.c uptime.c loadavg.c \
@@ -12,14 +16,12 @@ libgtop_sysdeps_la_SOURCES = open.c close.c cpu.c mem.c \
procmap.c netload.c netinfo.c ppp.c \
procdata.c interfaces.c
-libgtop_sysdeps_la_LDFLAGS = $(LT_VERSION_INFO) -module -export-dynamic
-
-libgtop_sysdeps_la_LIBADD = @DL_LIB@
+libgtop_sysdeps_la_LDFLAGS = $(LT_VERSION_INFO) $(dynamic_ldflags)
libgtop_sysdeps_suid_la_SOURCES = open_suid.c close_suid.c \
shm_limits.c msg_limits.c sem_limits.c
-libgtop_sysdeps_suid_la_LDFLAGS = $(LT_VERSION_INFO) -module -export-dynamic
+libgtop_sysdeps_suid_la_LDFLAGS = $(LT_VERSION_INFO) $(dynamic_ldflags)
include_HEADERS = glibtop_server.h glibtop_machine.h