summaryrefslogtreecommitdiff
path: root/sysdeps/solaris/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@home-of-linux.org>2000-02-22 21:01:14 +0000
committerMartin Baulig <martin@src.gnome.org>2000-02-22 21:01:14 +0000
commit5f0246b07d97aad992cdae24c74d58031decd954 (patch)
treea08d4c2e1579c684e9d9e000c57e20ea480ed5bd /sysdeps/solaris/Makefile.am
parentfa20de8904ffe0d72222cbb247c7d7268a69556a (diff)
downloadlibgtop-5f0246b07d97aad992cdae24c74d58031decd954.tar.gz
Only install the libs in $(LIBGTOP_BACKEND_DIR) when we
2000-02-22 Martin Baulig <martin@home-of-linux.org> * Makefile.am: Only install the libs in $(LIBGTOP_BACKEND_DIR) when we LIBGTOP_USE_GMODULE and in $(libdir) otherwise.
Diffstat (limited to 'sysdeps/solaris/Makefile.am')
-rw-r--r--sysdeps/solaris/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/sysdeps/solaris/Makefile.am b/sysdeps/solaris/Makefile.am
index 2d6c26bc..1eda61b7 100644
--- a/sysdeps/solaris/Makefile.am
+++ b/sysdeps/solaris/Makefile.am
@@ -6,7 +6,13 @@ dynamic_ldflags = @libgtop_dynamic_ldflags@
backenddir = @LIBGTOP_BACKEND_DIR@
-backend_LTLIBRARIES = libgtop_sysdeps.la libgtop_sysdeps_suid.la
+if LIBGTOP_USE_GMODULE
+backendlibdir = $(backenddir)
+else
+backendlibdir = $(libdir)
+endif
+
+backendlib_LTLIBRARIES = libgtop_sysdeps.la libgtop_sysdeps_suid.la
libgtop_sysdeps_la_SOURCES = open.c close.c cpu.c mem.c \
safeio.c swap.c uptime.c loadavg.c \