summaryrefslogtreecommitdiff
path: root/sysdeps/solaris/Makefile.am
diff options
context:
space:
mode:
authorMartin Baulig <martin@src.gnome.org>1999-03-17 18:29:40 +0000
committerMartin Baulig <martin@src.gnome.org>1999-03-17 18:29:40 +0000
commitc4ccf53aad1639200e1a31b6149188d27ac7b16b (patch)
tree2bb6f3ca527e2617eba1f753f137e83427fb183f /sysdeps/solaris/Makefile.am
parent8fe9163e6b7e4e31816668dc7fad7ced00c96303 (diff)
downloadlibgtop-c4ccf53aad1639200e1a31b6149188d27ac7b16b.tar.gz
Initial revision
Diffstat (limited to 'sysdeps/solaris/Makefile.am')
-rw-r--r--sysdeps/solaris/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/sysdeps/solaris/Makefile.am b/sysdeps/solaris/Makefile.am
new file mode 100644
index 00000000..ef7846b0
--- /dev/null
+++ b/sysdeps/solaris/Makefile.am
@@ -0,0 +1,18 @@
+LINK = $(LIBTOOL) --mode=link $(CC) $(CFLAGS) $(LDFLAGS) -o $@
+
+INCLUDES = @INCLUDES@
+
+lib_LTLIBRARIES = libgtop_sysdeps.la
+
+libgtop_sysdeps_la_SOURCES = open.c close.c siglist.c cpu.c mem.c swap.c \
+ uptime.c loadavg.c shm_limits.c msg_limits.c \
+ sem_limits.c proclist.c procstate.c procuid.c \
+ proctime.c procmem.c procsignal.c prockernel.c \
+ procsegment.c procargs.c procmap.c netload.c \
+ ppp.c procdata.c
+
+libgtop_sysdeps_la_LDFLAGS = $(LT_VERSION_INFO)
+
+include_HEADERS = glibtop_server.h glibtop_machine.h
+noinst_HEADERS = glibtop_private.h
+