summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d7215bf0..5426daf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,6 +71,16 @@ dnl Most people should have a working perl interpreter on their system
AC_CHECK_PROGS(PERL, perl5 perl)
test -z "$PERL" && AC_MSG_ERROR([You need to have a working perl interpreter.])
+case "${host_os}" in
+ linux*)
+ AC_CHECK_TOOL(LSBLK,lsblk)
+ AC_CHECK_TOOL(SED,sed)
+ AC_CHECK_TOOL(TR,tr)
+ ;;
+ *)
+ ;;
+esac
+
AC_CHECK_TOOL(CC,gcc)
AC_CHECK_TOOL(RANLIB,ranlib)
AC_CHECK_TOOL(AS,as)