summaryrefslogtreecommitdiff
path: root/libgweather/tools/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2022-09-03 13:37:46 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2022-09-10 18:38:33 +0100
commitda349aaf58b4facaa3a1720e8c973c9bffb4c887 (patch)
tree09007a615b481220e57c9d56e3d2d34558069c2a /libgweather/tools/meson.build
parenta4baf128a921957102cac0040ad07ff96b0262af (diff)
downloadlibgweather-da349aaf58b4facaa3a1720e8c973c9bffb4c887.tar.gz
build: Remove deprecated Meson functions
Use project_source_root() and project_build_root() instead of the deprecated source_root() and build_root(), respectively.
Diffstat (limited to 'libgweather/tools/meson.build')
-rw-r--r--libgweather/tools/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/libgweather/tools/meson.build b/libgweather/tools/meson.build
index b50e194..3a05ef1 100644
--- a/libgweather/tools/meson.build
+++ b/libgweather/tools/meson.build
@@ -15,10 +15,13 @@ tools = [
}
]
+schemas_srcdir = meson.project_source_root() / 'schemas'
+schemas_builddir = meson.project_build_root() / 'schemas'
+
tools_cargs = [
'-DTEST_LOCATIONS="@0@"'.format(locations_bin.full_path()),
- '-DSCHEMASDIR="@0@/schemas"'.format(meson.source_root()),
- '-DSCHEMAS_BUILDDIR="@0@/schemas"'.format(meson.build_root()),
+ '-DSCHEMASDIR="@0@"'.format(schemas_srcdir),
+ '-DSCHEMAS_BUILDDIR="@0@"'.format(schemas_builddir),
]
foreach tool: tools