summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-10-13 13:29:17 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2021-10-13 13:29:17 +0100
commit6352a74f0933955050573215dbee72f7be44510b (patch)
tree59a82657a271804542dd8a9f3528a02ef241b8dc /meson.build
parent7d98cfadae351d298d5f69d43d142c9da4ea7622 (diff)
downloadlibgweather-6352a74f0933955050573215dbee72f7be44510b.tar.gz
Remove GTK3 widgets
The GTK3 widgets cannot exist in the same process as other versions of GTK, which means applications cannot port to GTK4 and link to libgweather. If we want to add GTK widgets back to libgweather we are going to do so in a separate shared library, with a separate namespace.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 1 insertions, 15 deletions
diff --git a/meson.build b/meson.build
index 774342d..989b3c9 100644
--- a/meson.build
+++ b/meson.build
@@ -30,7 +30,6 @@ pkgdatadir = datadir / 'libgweather'
pkglibdir = libdir / 'libgweather'
glib_req_version = '>= 2.44.0'
-gtk_req_version = '>= 3.13.5'
libsoup_req_version = '>= 2.44.0'
libxml_req_version = '>= 2.6.0'
@@ -45,16 +44,6 @@ pylint_flags = [
'-d', 'C0326',
]
-if get_option('glade_catalog') == 'false'
- enable_glade_catalog = false
-else
- glade_dep = dependency('gladeui-2.0', required: get_option('glade_catalog') == 'true')
- enable_glade_catalog = glade_dep.found()
- if enable_glade_catalog
- glade_catalogdir = datadir / 'glade/catalogs'
- endif
-endif
-
gen_locations_variant = find_program('build-aux/meson/gen_locations_variant.py')
subdir('data')
@@ -73,11 +62,9 @@ pkgconfig.generate(
version: meson.project_version(),
libraries: lib_libgweather,
subdirs: libgweather_full_version,
- requires: [
- 'gtk+-3.0',
- ],
requires_private: [
'gio-2.0',
+ 'gdk-pixbuf-2.0',
'libsoup-2.4',
'libxml-2.0',
'geocode-glib-1.0',
@@ -96,7 +83,6 @@ summary({
summary({
'Debug': get_option('debug'),
'Optimization': get_option('optimization'),
- 'Glade catalog': enable_glade_catalog,
'Introspection': build_gir,
'Generate VAPI': build_vapi,
'API reference': get_option('gtk_doc'),