summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-10-16 23:55:47 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2021-10-17 00:37:04 +0100
commit86d24fff6cebfc34821a4c1cdd53f8a04b8d7dab (patch)
treebf65be693b31e9a9bafca48dd03a0991ffc8ccce /meson.build
parentada8a151d0780b4177cb52138c9080ed98ac5483 (diff)
downloadlibgweather-86d24fff6cebfc34821a4c1cdd53f8a04b8d7dab.tar.gz
build: Require pygobject
The locations binary blob generator depends on pygobject, so we should actually check for its presence during the configuration phase. Otherwise the configuration will pass, and then the build will fail, and we're going to look bad.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bef96ac..66a4591 100644
--- a/meson.build
+++ b/meson.build
@@ -45,6 +45,7 @@ pylint_flags = [
'-d', 'C0326',
]
+py = import('python').find_installation('python3', modules: ['gi'])
gen_locations_variant = find_program('build-aux/meson/gen_locations_variant.py')
subdir('data')