summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBenjamin Berg <bberg@redhat.com>2020-04-26 17:22:54 +0200
committerBastien Nocera <hadess@hadess.net>2020-07-01 16:39:04 +0000
commitf2535854bcfe4b4cd994282bc0416bc80ff310cb (patch)
tree0ca40b52a12756495e8151768e7dcb39165a8107 /meson.build
parent16028d23b2745fa8e78042a4e4aaf7344bdde29c (diff)
downloadlibgweather-f2535854bcfe4b4cd994282bc0416bc80ff310cb.tar.gz
build: Move pkgconfig generation into toplevel
This avoids a dependency of the data subdirectory to be included after the src subdirectory. This is done in preparation to support generating an in-memory database for the locations and being able to depend on that from the src subdirectory.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 98724ea..9bf8e75 100644
--- a/meson.build
+++ b/meson.build
@@ -124,3 +124,21 @@ endif
subdir('po')
subdir('po-locations')
meson.add_install_script('meson/meson_post_install.py')
+
+pkgconfig.generate(
+ filebase: 'gweather-3.0',
+ name: 'GWeather',
+ description: 'GWeather shared library',
+ version: meson.project_version(),
+ libraries: lib_libgweather,
+ subdirs: 'libgweather-3.0',
+ requires: [
+ 'gtk+-3.0',
+ ],
+ requires_private: [
+ 'gio-2.0',
+ 'libsoup-2.4',
+ 'libxml-2.0',
+ 'geocode-glib-1.0',
+ ],
+)