summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBenjamin Berg <bberg@redhat.com>2020-04-25 23:23:23 +0200
committerBastien Nocera <hadess@hadess.net>2021-01-11 20:31:52 +0100
commitf4f8bd4b808722a3274783f60ffbab9437114c29 (patch)
treef106ccfa85362971fa967b62856a0c08f967135b /meson.build
parent5bdaac8f0b32d0a031503d5f56acaf87dc43c840 (diff)
downloadlibgweather-f4f8bd4b808722a3274783f60ffbab9437114c29.tar.gz
gweather: Port to new GVariant based in-memory DB
This makes GWeather use a memory mapped GVariant as an in-memory database. Doing this allows much faster access and decreases memory consumption considerably as items can be fetched from the database on-demand.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index bd3b331..66dc23b 100644
--- a/meson.build
+++ b/meson.build
@@ -60,7 +60,7 @@ config_h.set_quoted('GETTEXT_PACKAGE', GETTEXT_PACKAGE)
config_h.set_quoted('LOCALEDIR', join_paths(datadir, 'locale'))
config_h.set_quoted('GNOMELOCALEDIR', join_paths(datadir, 'locale'))
config_h.set_quoted('G_LOG_DOMAIN', 'GWeather')
-config_h.set_quoted('GWEATHER_XML_LOCATION_DIR', pkgdatadir)
+config_h.set_quoted('GWEATHER_BIN_LOCATION_DIR', pkglibdir)
config_h.set_quoted('LIBGWEATHER_VERSION', meson.project_version())
if c_compiler.has_member('struct tm', 'tm_gmtoff', prefix: '#include <time.h>')