summaryrefslogtreecommitdiff
path: root/libgweather/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'libgweather/tests/meson.build')
-rw-r--r--libgweather/tests/meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/libgweather/tests/meson.build b/libgweather/tests/meson.build
index eefe2a3..b1f906b 100644
--- a/libgweather/tests/meson.build
+++ b/libgweather/tests/meson.build
@@ -1,6 +1,9 @@
+schemas_srcdir = meson.project_source_root() / 'schemas'
+schemas_builddir = meson.project_build_root() / 'schemas'
+
gweather_test_cargs = [
- '-DSCHEMASDIR="@0@/schemas"'.format(meson.source_root()),
- '-DSCHEMAS_BUILDDIR="@0@/schemas"'.format(meson.build_root()),
+ '-DSCHEMASDIR="@0@"'.format(schemas_srcdir),
+ '-DSCHEMAS_BUILDDIR="@0@"'.format(schemas_builddir),
]
gweather_test_env = environment()