summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2021-05-17 14:16:21 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2021-05-20 14:07:04 +0100
commit7f33cf1913e90e3b8cc9c2546cb860f4c1d66d99 (patch)
tree72b592488883b11a64b6faab3bfffd6e57b012cc /meson.build
parentdfce98d730a389f6300dc3ae285c0ac985dc1740 (diff)
downloadlibmediaart-7f33cf1913e90e3b8cc9c2546cb860f4c1d66d99.tar.gz
build: Use the built-in summary()
Instead of hand-rolling our own. Remove the bit about the C compiler: Meson prints out the compiler in its default output. Similarly, remove the bit about the source directory: Meson does that automatically.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 4 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 39791c9..704cba0 100644
--- a/meson.build
+++ b/meson.build
@@ -123,12 +123,8 @@ pkgconfig.generate(
requires_private: image_library_name,
libraries_private: ['-lz', '-lm'])
-summary = [
- '\nBuild Configuration:',
- ' Prefix: ' + get_option('prefix'),
- ' Source code location: ' + meson.source_root(),
- ' Compiler: ' + cc.get_id(),
- ' Image processing library: ' + image_library_name,
-]
+summary('prefix', get_option('prefix'), section: 'Directories')
+summary('includedir', get_option('includedir'), section: 'Directories')
+summary('libdir', get_option('libdir'), section: 'Directories')
-message('\n'.join(summary))
+summary('Image processing library', image_library_name, section: 'Build')