summaryrefslogtreecommitdiff
path: root/loaders/meson.build
diff options
context:
space:
mode:
authorMartin Blanchard <tchaik@gmx.com>2018-06-02 17:45:30 +0100
committerChristian Hergert <chergert@redhat.com>2019-08-05 13:17:56 -0700
commitdabb83a2e217694220a55c2019a081365a4a1288 (patch)
treedbf8bc0f074db21657464eb6e4531bb6ad0f218b /loaders/meson.build
parentdd795bd071d9cec755979a3942682a331c429360 (diff)
downloadlibpeas-dabb83a2e217694220a55c2019a081365a4a1288.tar.gz
Port to meson build system
The meson build system focuses on speed an ease of use, which helps speeding up the software development. https://bugzilla.gnome.org/show_bug.cgi?id=793916 https://gitlab.gnome.org/GNOME/libpeas/issues/26 Closes #26
Diffstat (limited to 'loaders/meson.build')
-rw-r--r--loaders/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/loaders/meson.build b/loaders/meson.build
new file mode 100644
index 0000000..7b9ce98
--- /dev/null
+++ b/loaders/meson.build
@@ -0,0 +1,11 @@
+if build_lua51_loader == true
+ subdir('lua5.1')
+endif
+
+if build_python3_loader == true
+ subdir('python')
+endif
+
+if build_python3_loader == true
+ subdir('python3')
+endif