summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTom Schoonjans <Tom.Schoonjans@diamond.ac.uk>2019-09-10 09:50:46 +0100
committerChristian Hergert <chergert@redhat.com>2019-10-28 10:11:45 -0700
commit6b8f695ac8acb0f6e39bce76f873398974cd661b (patch)
tree8d3c3960fb2a3b6dcbc48ae5c353a2c55a5c2d26 /meson.build
parentd1248f5548524bae66ed3a67ad0a19f20fd56956 (diff)
downloadlibpeas-6b8f695ac8acb0f6e39bce76f873398974cd661b.tar.gz
meson: build loaders as modules instead of shared libraries
Also: ensure that the extension of the loader plugins is set to so on macOS
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 56813ab..b0290dc 100644
--- a/meson.build
+++ b/meson.build
@@ -133,9 +133,11 @@ add_project_arguments([
'-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_@0@_@1@'.format(glib_major_version, glib_minor_version),
], language: 'c')
+module_suffix = []
if build_machine.system() == 'darwin'
config_h.set('OS_OSX', 1)
add_languages('objc')
+ module_suffix = 'so'
endif
# Detect and set symbol visibility