summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristian Hergert <chergert@redhat.com>2022-02-08 17:37:09 -0800
committerChristian Hergert <chergert@redhat.com>2022-02-08 17:37:09 -0800
commit7e007a651120ef4a9043afc9ef0b1c140731eae9 (patch)
tree3e1bdade169b18fd7ce4412148ae3ef78f9c98bc /meson.build
parentd150c9dd65027aab82b2cae7507d073ef0414a47 (diff)
downloadlibpeas-7e007a651120ef4a9043afc9ef0b1c140731eae9.tar.gz
build: fix min/max version warnings
We don't want these applied to the gir compilation, so manually add the project_c_args to the targets we care about having min/max glib version applied.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index ccb3c6c..ba250ea 100644
--- a/meson.build
+++ b/meson.build
@@ -214,10 +214,10 @@ glib_version_arr = glib_req_version.split('.')
glib_major_version = glib_version_arr[0]
glib_minor_version = glib_version_arr[1]
-add_project_arguments([
+project_c_args = [
'-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_@0@_@1@'.format(glib_major_version, glib_minor_version),
'-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_@0@_@1@'.format(glib_major_version, glib_minor_version),
-], language: 'c')
+]
module_suffix = []
if build_machine.system() == 'darwin'