summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2019-11-15 14:32:34 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2020-10-09 09:32:26 +0800
commitc34c89ca4ac5b1688e580341e8703fbbdd79dfda (patch)
tree8072fef486a269818d63d709dfcdbc398eb4fdf5 /meson.build
parentc882c281913d37e76ee9b839c5b4845de8094787 (diff)
downloadlibpeas-c34c89ca4ac5b1688e580341e8703fbbdd79dfda.tar.gz
meson: Don't use 'cp' to copy files
'cp' is a UNIX/BASH shell-only command, which does not exist on standard Windows cmd.exe shells by default, so use a Python script that tries to do similar things.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 56aa7c3..7efb71b 100644
--- a/meson.build
+++ b/meson.build
@@ -258,6 +258,9 @@ if build_python3_loader and not python3_found
build_python3_loader = false
endif
+# Replace 'cp' calls
+copyfile_script = find_program('copyfile.py')
+
subdir('libpeas')
if build_gtk_widgetry == true
subdir('libpeas-gtk')