summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristian Hergert <chergert@redhat.com>2023-03-16 16:43:45 -0700
committerChristian Hergert <chergert@redhat.com>2023-03-22 16:44:35 -0700
commitc5c1452307721cd1e216b8faaff99ed83ed94e4b (patch)
tree75cb2810d4e646f6a4e5d746b46629d3bc5da961 /meson.build
parent46cf665494b7602b2aed8cb156415236f828e112 (diff)
downloadlibpeas-c5c1452307721cd1e216b8faaff99ed83ed94e4b.tar.gz
janitorial: add LIBPEAS_INSIDE include checks
Make sure that only <libpeas.h> is included directly. Additionally this ensures we always have LIBPEAS_COMPILATION set when building libpeas.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8a1b38b..64b5918 100644
--- a/meson.build
+++ b/meson.build
@@ -204,7 +204,9 @@ glib_minor_version = glib_version_arr[1]
project_c_args = [
'-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_@0@_@1@'.format(glib_major_version, glib_minor_version),
'-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_@0@_@1@'.format(glib_major_version, glib_minor_version),
+ '-DLIBPEAS_COMPILATION',
]
+add_project_arguments(project_c_args, language: 'c')
global_c_args = []
test_c_args = [