summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFelix Riemann <friemann@gnome.org>2019-12-08 18:00:53 +0100
committerFelix Riemann <friemann@gnome.org>2019-12-08 18:00:53 +0100
commite7b19f64b18813391fb149b76c3086c43f3f315d (patch)
treeb1add1035e1c2db8ada767d00a7ba492b704cf70 /meson.build
parentac13e59886b1a5ebc05ca12dc354f95a1c28c5f5 (diff)
downloadlibpeas-e7b19f64b18813391fb149b76c3086c43f3f315d.tar.gz
meson: Fix handling of 'demos' parameter
Internally the build script evaluated the 'widgetry' parameter instead which is just a dependency of 'demos'. Evaluate the correct parameter to show the correct state in the build summary. Also drop the now obsolete duplicate check in peas-demo's meson script.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5abb4bb..44938cd 100644
--- a/meson.build
+++ b/meson.build
@@ -206,7 +206,7 @@ if build_gtk_widgetry and not gtk_dep.found()
build_gtk_widgetry = false
endif
-build_demos = get_option('widgetry')
+build_demos = get_option('demos')
if build_demos and not build_gtk_widgetry
build_demos = false
endif