summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorChristian Hergert <chergert@redhat.com>2023-03-22 16:44:31 -0700
committerChristian Hergert <chergert@redhat.com>2023-03-22 16:44:31 -0700
commit37b9fae8ab0f31f64761762cb1693807add68613 (patch)
treece2d72f42b97fa679f7bf56076b6978d9354f878 /meson_options.txt
parentc68ecac0025caa5fa2401deff41d3b1959062600 (diff)
downloadlibpeas-37b9fae8ab0f31f64761762cb1693807add68613.tar.gz
janitorial: clean up tree in preparation for libpeas-2.0
This starts the process of working towards a new Libpeas 2.0 ABI. The goals of this ABI break are: * Modernize and cleanup GObject usage within libpeas * Use GObject's in more places to allow for better GIO integration * Implement GListModel where it makes sense * Remove GTK 3 and GTK-based APIs as those are trivial to implement in applications with GTK 4 and newer. * Drop Python 2 support * Simplify support for new plugin loaders # Conflicts: # NEWS # meson.build
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/meson_options.txt b/meson_options.txt
index cb21e45..7ff25b9 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -2,16 +2,10 @@ option('lua51',
type: 'boolean', value: true,
description: 'Enable Lua 5.1 support (requires lua-lgi)')
-option('python2',
- type: 'boolean', value: false,
- description: 'Enable Python 2 support (requires pygobject)')
option('python3',
type: 'boolean', value: true,
description: 'Enable Python 3 support (requires pygobject)')
-option('python2_path',
- type: 'string', value: '',
- description: 'Path to Python 2.x interpreter (Windows only)')
option('python3_path',
type: 'string', value: '',
description: 'Path to Python 3.x interpreter (Windows only)')
@@ -23,13 +17,6 @@ option('vapi',
type: 'boolean', value: false,
description: 'Generate vapi data (requires vapigen)')
-option('widgetry',
- type: 'boolean', value: true,
- description: 'Build GTK+ widgetry (requires gtk+)')
-option('glade_catalog',
- type: 'boolean', value: true,
- description: 'Install Glade catalog (requires gladeui)')
-
option('demos',
type: 'boolean', value: true,
description: 'Build demo programs')