summaryrefslogtreecommitdiff
path: root/rest/meson.build
diff options
context:
space:
mode:
authorGünther Wagner <info@gunibert.de>2021-12-28 16:46:10 +0100
committerGünther Wagner <info@gunibert.de>2022-01-12 19:47:12 +0100
commitb6b20dae6f06a3badc6be09532d735a375b62e19 (patch)
tree3dd25cd3bea315d841076547dc61ecbeae4b2e05 /rest/meson.build
parentb71c932a64e4060c2cbce05aac040e1c6d7dc43f (diff)
downloadlibrest-b6b20dae6f06a3badc6be09532d735a375b62e19.tar.gz
params: reworked to boxed and list
RestParams was implemented as HashTable. Limitations are that it did not preserved the order of individual parameters aswell as duplicates aren't allowed. Reworked it to a GList and introduced reference counting and a boxed type.
Diffstat (limited to 'rest/meson.build')
-rw-r--r--rest/meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/rest/meson.build b/rest/meson.build
index a22742e..58dfbd8 100644
--- a/rest/meson.build
+++ b/rest/meson.build
@@ -87,12 +87,11 @@ if get_option('introspection')
endforeach
librest_gir = gnome.generate_gir(librest_lib,
- sources: [ librest_headers, librest_sources, librest_enums[1] ],
- dependencies: librest_deps,
+ sources: librest_sources + librest_headers + librest_enums,
+ nsversion: librest_api_version,
namespace: 'Rest',
- identifier_prefix: 'Rest',
symbol_prefix: 'rest',
- nsversion: librest_api_version,
+ identifier_prefix: 'Rest',
includes: [ 'GObject-2.0', 'Gio-2.0', 'Soup-@0@'.format(libsoup_api_version) ],
extra_args: librest_gir_extra_args,
install: true,