summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2017-03-02 17:25:41 +0100
committerLubomir Rintel <lkundrak@v3.sk>2017-03-19 21:06:16 +0100
commit0da2398042bd8dccfdf63abf76b4d6b0679e4803 (patch)
treeb695ed4109dde995971c4a5fbe7d335d6d662e0a /Makefile.am
parent3318272f0eb9264d57fbdebb54163fa818b90fde (diff)
downloadnetwork-manager-applet-0da2398042bd8dccfdf63abf76b4d6b0679e4803.tar.gz
libnma: add a certificate picker interface
A grid with certificate & key pair optionally with passwords. The idea is to provide reusable interface for the 802.1x and VPN plugins that can be backed by a simple file-base chooser or a PKCS#11 based chooser. The API is designed with possible future Gcr certificate chooser in mind. This is available from libnm-gtk too, since the wireless-security library will make use for it. It still resides in the libnma/ tree not to introduce complexity into how the tree is organized for the sake of a legacy component.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index ed407ac7..4a3505cc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -350,7 +350,8 @@ libnm_gtk_h_pub = \
src/libnm-gtk/nm-mobile-wizard.h \
src/libnm-gtk/nm-ui-utils.h \
src/libnm-gtk/nm-mobile-providers.h \
- src/libnm-gtk/nm-vpn-password-dialog.h
+ src/libnm-gtk/nm-vpn-password-dialog.h \
+ src/libnm-gtk/nm-cert-chooser.h
libnm_gtk_c_real = \
src/libnm-gtk/nm-wifi-dialog.c \
@@ -359,6 +360,7 @@ libnm_gtk_c_real = \
src/libnm-gtk/nm-ui-utils.c \
src/libnm-gtk/nm-mobile-providers.c \
src/libnm-gtk/nm-vpn-password-dialog.c \
+ src/libnma/nma-cert-chooser.c \
src/libnm-gtk/init.c
src_libnm_gtk_libnmgtkdir = $(includedir)/libnm-gtk
@@ -479,7 +481,8 @@ libnma_h_pub = \
src/libnma/nma-mobile-wizard.h \
src/libnma/nma-mobile-providers.h \
src/libnma/nma-vpn-password-dialog.h \
- src/libnma/nma-ui-utils.h
+ src/libnma/nma-ui-utils.h \
+ src/libnma/nma-cert-chooser.h
libnma_c_real = \
src/libnma/nma-wifi-dialog.c \
@@ -487,7 +490,8 @@ libnma_c_real = \
src/libnma/nma-mobile-providers.c \
src/libnma/nma-vpn-password-dialog.c \
src/libnma/nma-ui-utils.c \
- src/libnma/init.c
+ src/libnma/init.c \
+ src/libnma/nma-cert-chooser.c
src_libnma_libnmadir = $(includedir)/libnma