summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2017-02-09 16:51:20 +0100
committerThomas Haller <thaller@redhat.com>2017-02-09 18:23:21 +0100
commit52af60920f569fd7c7eefaa9d3c000c050da71be (patch)
treed0f64ea0aff13c2176f5bbeef26c4af310cc6f5c /Makefile.am
parentb308cd4be4b0a1c15785f79d2dd9f5a5adaccad8 (diff)
downloadnetwork-manager-applet-52af60920f569fd7c7eefaa9d3c000c050da71be.tar.gz
build: add direct dependencies instead using BUILT_SOURCES (5)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 18 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 366c8794..0b2e0642 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -693,23 +693,23 @@ EXTRA_DIST += \
###############################################################################
-BUILT_SOURCES += \
- src/applet-resources.h \
- src/applet-resources.c
-
src/applet-resources.h: src/applet.gresource.xml
$(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) $< --target=$@ --sourcedir=$(srcdir)/src --generate-header --internal
src/applet-resources.c: src/applet.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir)/src --generate-dependencies $(srcdir)/src/applet.gresource.xml)
$(AM_V_GEN) $(GLIB_COMPILE_RESOURCES) $< --target=$@ --sourcedir=$(srcdir)/src --generate-source --internal
+CLEANFILES += \
+ $(nm_applet_h_gen) \
+ $(nm_applet_c_gen)
-bin_PROGRAMS += src/nm-applet
+nm_applet_h_gen = \
+ src/applet-resources.h
-src_nm_applet_SOURCES = \
- src/applet-resources.h \
- src/applet-resources.c \
- \
+nm_applet_c_gen = \
+ src/applet-resources.c
+
+nm_applet_hc_real = \
src/main.c \
src/applet.c \
src/applet.h \
@@ -736,11 +736,18 @@ src_nm_applet_SOURCES = \
src/fallback-icon.h
if WITH_WWAN
-src_nm_applet_SOURCES += \
+nm_applet_hc_real += \
src/applet-device-broadband.h \
src/applet-device-broadband.c
endif
+bin_PROGRAMS += src/nm-applet
+
+src_nm_applet_SOURCES = \
+ $(nm_applet_h_gen) \
+ $(nm_applet_c_gen) \
+ $(nm_applet_hc_real)
+
src_nm_applet_CPPFLAGS = \
-DNM_VERSION_MIN_REQUIRED=NM_VERSION_1_4 \
-DNM_VERSION_MAX_ALLOWED=NM_VERSION_1_4 \
@@ -774,6 +781,7 @@ src_nm_applet_LDADD = \
$(APPINDICATOR_LIBS) \
-lm
+$(src_nm_applet_OBJECTS): $(nm_applet_h_gen)
EXTRA_DIST += \
src/8021x.ui \