summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <william.jon.mccann@gmail.com>2009-08-25 17:57:16 -0500
committerDan Williams <dcbw@redhat.com>2009-08-25 17:57:16 -0500
commit5c98dafd0c2b19d7884a35efcc37714c97a7fb3a (patch)
tree574636a16040c321860048d858b5619cc6d658d9 /Makefile.am
parentdabc37a396d728b2f4d7d8b4842e3af10ef405f1 (diff)
downloadnetwork-manager-applet-5c98dafd0c2b19d7884a35efcc37714c97a7fb3a.tar.gz
gconf: add schemas for applet values like notification prefs
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 50441e2b..e7098b44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,7 +28,14 @@ desktop_in_files = nm-connection-editor.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
+schemasdir = @GCONF_SCHEMA_FILE_DIR@
+schemas_in_files = nm-applet.schemas.in
+schemas_DATA = $(schemas_in_files:.schemas.in=.schemas)
+@INTLTOOL_SCHEMAS_RULE@
+
+
EXTRA_DIST += \
+ $(schemas_in_files) \
$(autostart_in_files) \
$(desktop_in_files) \
$(DBUS_126_CONF) \
@@ -37,8 +44,18 @@ EXTRA_DIST += \
CLEANFILES = \
$(autostart_DATA) \
$(desktop_DATA) \
+ $(schemas_DATA) \
$(dbusservice_DATA)
DISTCLEANFILES = intltool-extract intltool-merge intltool-update
ACLOCAL_AMFLAGS = -I m4
+
+install-data-local:
+if GCONF_SCHEMAS_INSTALL
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schemas_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(top_builddir)/$$p >&1 > /dev/null; \
+ done \
+ fi
+endif