summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2019-02-26 17:37:02 +0100
committerLubomir Rintel <lkundrak@v3.sk>2019-02-26 20:02:32 +0100
commitb3c89c31f8f0ee2cc7ae3e094938846813345d57 (patch)
tree1147614288f44013efb0271459af2bf9ed94e84e /Makefile.am
parent8539d03c51fb6c9c54c28c8a9f7fa388817fa0e9 (diff)
downloadnetwork-manager-applet-b3c89c31f8f0ee2cc7ae3e094938846813345d57.tar.gz
build: replace intltool with gettext
Gettext, since version 0.18, provides infrastructure equivalent to intltool (generating po/Makefile and translating .desktop files or .xml). Also, it seems to work better in that it actually honors MSGFMT_OPTS that are determined by the configure script. That one typically ends up set to "-c", meaning "check". Without it the bugs in the .po files are easy to overlook.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 9 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 46095319..d0c43aca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1070,9 +1070,6 @@ TESTS += $(check_programs)
EXTRA_DIST += \
linker-script-binary.ver \
CONTRIBUTING \
- intltool-extract.in \
- intltool-merge.in \
- intltool-update.in \
Makefile.glib \
autogen.sh \
meson.build \
@@ -1088,13 +1085,18 @@ autostartdir = $(sysconfdir)/xdg/autostart
autostart_in_files = nm-applet.desktop.in
autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
+nm-applet.desktop: nm-applet.desktop.in
+ $(AM_V_GEN)$(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
+
applicationsdir = $(datadir)/applications
applications_DATA = $(autostart_DATA)
desktopdir = $(datadir)/applications
desktop_in_files = nm-connection-editor.desktop.in
desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
+
+nm-connection-editor.desktop: nm-connection-editor.desktop.in
+ $(AM_V_GEN)$(MSGFMT) --desktop --template $< -d $(top_srcdir)/po -o $@
gsettings_SCHEMAS = org.gnome.nm-applet.gschema.xml
@GSETTINGS_RULES@
@@ -1102,7 +1104,9 @@ gsettings_SCHEMAS = org.gnome.nm-applet.gschema.xml
appdatadir = $(datadir)/metainfo
appdata_DATA = $(appdata_in_files:.xml.in=.xml)
appdata_in_files = nm-connection-editor.appdata.xml.in
-@INTLTOOL_XML_RULE@
+
+nm-connection-editor.appdata.xml: nm-connection-editor.appdata.xml.in
+ $(AM_V_GEN)$(MSGFMT) --xml --template $< -d $(top_srcdir)/po -o $@
convertdir=$(datadir)/GConf/gsettings
convert_DATA=nm-applet.convert
@@ -1121,8 +1125,3 @@ CLEANFILES += \
$(desktop_DATA) \
$(appdata_DATA) \
$(BUILT_SOURCES)
-
-DISTCLEANFILES += \
- intltool-extract \
- intltool-merge \
- intltool-update