summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2019-02-15 17:19:47 +0100
committerLubomir Rintel <lkundrak@v3.sk>2019-02-18 15:08:27 +0100
commit1eb17ef9e3acb22123fb49078eb25679bad61f93 (patch)
tree60ce8330cf00e969eb9b39ade9f57e37e8b2cb58 /configure.ac
parentb4c365b136e25e69c3550a9984f8f3cbec4bc073 (diff)
downloadnetwork-manager-applet-1eb17ef9e3acb22123fb49078eb25679bad61f93.tar.gz
build: fix required GTK3 version
The GtkBuilder files and the autoconf script all depend on 3.10. However, a few places were left where 3.4 was forgotten. Also "GTK_VERSION" was used instead of "GDK_VERSION" in some spots -- fix that too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 10a92f56..42a49716 100644
--- a/configure.ac
+++ b/configure.ac
@@ -163,7 +163,7 @@ fi
PKG_CHECK_MODULES(NOTIFY, [libnotify >= 0.4.3])
PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.10)
-GTK3_CFLAGS="$GTK3_CFLAGS -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_4 -DGTK_VERSION_MAX_ALLOWED=GTK_VERSION_3_4"
+GTK3_CFLAGS="$GTK3_CFLAGS -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_3_10 -DGDK_VERSION_MAX_ALLOWED=GDK_VERSION_3_10"
AC_ARG_WITH([appindicator],
AS_HELP_STRING([--with-appindicator=no|yes|auto|ayatana|ubuntu], [Build with lib(ayatana-)appindicator support in addition to xembed systray support.]),