summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarco Barisione <marco.barisione@collabora.co.uk>2013-05-17 15:20:31 +0100
committerMarco Barisione <marco.barisione@collabora.co.uk>2013-08-20 11:11:36 +0100
commit17d9fcfb213b1c00368a3c134bc9e60b1526d02d (patch)
treea023881fc6af3c471967d1eb9ba26b19a7273b1c /Makefile.am
parent6822599c7c07d11c8a7fe4c6de42774884a77d1d (diff)
downloadtelepathy-account-widgets-17d9fcfb213b1c00368a3c134bc9e60b1526d02d.tar.gz
Makefile.am: don't generate a ChangeLog, it's not useful for a submodule
https://bugzilla.gnome.org/show_bug.cgi?id=699492
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 0 insertions, 25 deletions
diff --git a/Makefile.am b/Makefile.am
index b8fb2171..453798fb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,35 +9,10 @@ DISTCHECK_CONFIGURE_FLAGS = \
EXTRA_DIST = \
CONTRIBUTORS \
COPYING.LGPL \
- ChangeLog \
README \
autogen.sh \
$(NULL)
-DISTCLEANFILES = \
- ChangeLog
-
# Workaround broken scrollkeeper that doesn't remove its files on
# uninstall.
distuninstallcheck_listfiles = find . -type f -print | grep -v '^\./var/scrollkeeper'
-
-distclean-local:
- if test "x$(srcdir)" = "x."; then :; else \
- rm -f ChangeLog; \
- fi
-
-ChangeLog:
- @echo Creating $@
- @if test -d "$(srcdir)/.git"; then \
- (GIT_DIR=$(top_srcdir)/.git ./missing --run git log EMPATHY_2_27_1.. --stat) | fmt --split-only > $@.tmp \
- && mv -f $@.tmp $@ \
- || ($(RM) $@.tmp; \
- echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
- (test -f $@ || echo git-log is required to generate this file >> $@)); \
- else \
- test -f $@ || \
- (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
- echo A git checkout and git-log is required to generate this file >> $@); \
- fi
-
-.PHONY: ChangeLog