summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2007-12-29 15:49:47 +0000
committerXavier Claessens <xclaesse@src.gnome.org>2007-12-29 15:49:47 +0000
commitb8607414ea0e41c44a09d31ebcd0437a3c867a24 (patch)
tree0004eceb52b4bb3a4da1275057e46ea80e840a05 /Makefile.am
parent736ff5bf9f668528f1a1db1c8c135a8165a1b044 (diff)
downloadtelepathy-account-widgets-b8607414ea0e41c44a09d31ebcd0437a3c867a24.tar.gz
merge git work
svn path=/trunk/; revision=518
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 2d207666..4256f0f8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,7 +33,6 @@ EXTRA_DIST = \
$(INTLTOOL)
DISTCLEANFILES = \
- ChangeLog \
intltool-extract \
intltool-merge \
intltool-update
@@ -42,9 +41,15 @@ DISTCLEANFILES = \
# uninstall.
distuninstallcheck_listfiles = find . -type f -print | grep -v '^\./var/scrollkeeper'
-ChangeLog: Makefile.am
- git-log --pretty=short > ChangeLog
-
+# Build ChangeLog from SVN history (r470 was the first ChangeLog-less checkin).
+# Only build this when in an svn checkout.
+
+ChangeLog:
+ @if test -f $(top_srcdir)/.svn/entries; then \
+ svn log -v --xml -r HEAD:470 $(SVN_ROOT)/$(SVN_MODULE) | \
+ xsltproc --stringparam strip-prefix "$(SVN_MODULE)/$(SVN_BRANCH)" \
+ --stringparam include-rev "yes" $(top_srcdir)/svn2cl.xsl - > $@; \
+ fi
dist: ChangeLog